Members | Sign In
Weblogic Wonders > Weblogic Server General
avatar

Ldap sync issue - Error while executing Synchronization Task due to :java.lang.ArrayIndexOutOfBoundsException: 10

posted Feb 23, 2018 15:02:24 by bhanu
Please help out guys with your vaulable suggestions
when we save password in ldap.propfile and run Ldap sync in application getting this error
Ldap sync issue :the password change actually was successful because we can log into the server using the SLA Username and password the error has to be somewherein Weblogic.

Note- Our application COTS package means its product which we brought from vendor and using it ....so absolutely no code changes are accepted and even we cannot change code no access to it

Error----Error while executing Synchronization Task due to :java.lang.ArrayIndexOutOfBoundsException: 10


Note**- we can successfully login into our server using password but the problem is our application is not working with the password,we got an LDAP sync error which means our Application is not working with password but the password is working on the server

Process

1.we will encrypt password which Ad people sent us on out test server
2.then we will save encrypted password in our properties files and restart weblogic
3.we will go to application and profiles just we hit Run Ldap sync and save it so it will automatically kick off the server so password will changed instead we are getting this error
***We use weblogic to run our application backend

Please help me out

Below is the log

2018-01-19 08:15:25,776 [Timer-12] INFO com.etq.reliance.timers.LdapSyncTask - Started task: Run LDAP Synchronization Task
2018-01-19 08:15:25,854 [Timer-12] INFO com.etq.reliance.ldap.LdapConnection - Connected Successfully to LDAP service using the default username: SRVC-ESC-AMC-ETQ@faa.gov
2018-01-19 08:15:25,885 [Timer-12] ERROR com.etq.reliance.ldap.listeners.UsersSyncTaskLogger - Error while executing Synchronization Task due to :java.lang.ArrayIndexOutOfBoundsException: 10
at weblogic.rjvm.RJVMFinder.<init>(Line:99)
at weblogic.rjvm.ServerURL.getFinder(Line:181)
at weblogic.rjvm.ServerURL.findOrCreateRJVM(Line:153)
at weblogic.jndi.WLInitialContextFactoryDelegate$1.run(Line:345)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Line:363)
at weblogic.security.service.SecurityManager.runAs(Line:146)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(Line:340)
at weblogic.jndi.Environment.getContext(Line:315)
at weblogic.jndi.Environment.getContext(Line:285)
at weblogic.jndi.WLInitialContextFactory.getInitialContext(Line:117)
at javax.naming.spi.NamingManager.getInitialContext(Line:667)
at javax.naming.InitialContext.getDefaultInitCtx(Line:288)
at javax.naming.InitialContext.init(Line:223)
at javax.naming.ldap.InitialLdapContext.<init>(Line:134)
at com.etq.reliance.ldap.LdapConnection.connectUsingDefaultUser(Line:188)
at com.etq.reliance.ldap.LdapSynchronizer.setConnections(Line:105)
at com.etq.reliance.ldap.LdapSynchronizer.prepareConfiguration(Line:57)
at com.etq.reliance.ldap.LdapSynchronizer.execute(Line:67)
at com.etq.reliance.timers.LdapSyncTask.runTask(Line:34)
at com.etq.reliance.timers.TaskBase.startTask(Line:135)
at com.etq.reliance.timers.TaskBase.run(Line:128)
at java.util.TimerThread.mainLoop(Line:512)
at java.util.TimerThread.run(Line:462)

Please help me out guys it very imp issue

upto date what we did


-restarted ldap server

-I have tried to change password using different SLA and Password on our test environment today. I have changed both SLA and Password on our both LDAP files and run Ldap sync still producing the same error

-Apart from this initially I have tested giving less characters password and encrypted it but it does not reflect any changes same as before and this is not password issue the password given was correct ( i mean good enough I.e min of 12 charaters)

-restarted weblogic server when ever we change password
Our LDAP itself different server
Login below to reply: